最近の投稿

ページ: [1] 2 3 ... 10
1
製作上のご質問 / Gateのノイズ
« 最新の投稿 by thunder 投稿日: 4月 16, 2017, 03:51:52 pm »
Analog2.0がほぼ完成したのですが、どうしてもGateで動かしたときのノイズが気になります。Gateが上がったときにぷつっという音が鳴ります。
EGを使っているときは気にならないのですが、GateでVCAを使うと、特にフィルターをかけたときや、シーケンサーを使ったときに目立ってしまいます。
VCAの調整でなんとかならないか試してみましたが、だめでした。何かアドバイスありましたら、お願いします。
2
製作上のご質問 / Re:VCOのピッチについて
« 最新の投稿 by thunder 投稿日: 3月 22, 2017, 12:57:50 pm »
そうでしたか!ありがとうございます、参考にします!
3
製作上のご質問 / Re:VCOのピッチについて
« 最新の投稿 by ushigomepan 投稿日: 3月 16, 2017, 09:06:52 pm »
thunderさん、はじめまして。

>ロータリースイッチでVCOのオクターブ切り替え

この件については過去記事があります。

作品の紹介・製作情報>VCO の RANGE をロータリースイッチに変更してみました

を読んでみてください。あるいはネット上にあるMini Moog等の回路図を参照するとか。
4
製作上のご質問 / VCOのピッチについて
« 最新の投稿 by thunder 投稿日: 3月 09, 2017, 04:12:03 pm »
2VCOにしたときのために、ロータリースイッチでVCOのオクターブ切り替えができるようにしたいのですが、可能でしょうか。
ロータリースイッチで抵抗を切り替えるような回路でできると思うのですが、具体的に抵抗値をどう設計すべきかわかりません。
よろしくお願いします。
5
製作上のご質問 / Re:Mini Board IIの動作
« 最新の投稿 by thunder 投稿日: 3月 09, 2017, 04:09:09 pm »
返事がおそくなってしまい、申し訳ありません。

MIDIの問題はMIDIコントローラー側にあったようで、現在は正しく機能しております。ご助言ありがとうございました。
また別件でご質問させていただきたいので、新しくスレッドを立てます。よろしくお願いします。
6
製作上のご質問 / Re:Mini Board IIの動作
« 最新の投稿 by Gan 投稿日: 1月 17, 2017, 05:58:00 pm »
引用
ただ、MIDIコンで演奏していると時々Gateが上がりっぱなしになってしまいます。また、ピッチベンドに反応するのですが、ピッチベンド後と前でかなり音程に差があります。
この点について何かご指導いただければ幸いです。

これは、マイクロプロセッサのプログラムにバグがあるか、MIDI 信号が時々マイクロプロセッサに届いていないかどちらかの可能性が高いと思います。MIDI の音を出すメッセージは、NOTE ON と NOTE OFF の二種類があり、NOTE OFF を受け逃すと音が出っぱなし、つまり Gate が立ち上がりっぱなしになります。ピッチベンドも、上がったベンドは明示的に 0 に戻さないと戻りません。何らかの原因でベンドを戻すメッセージを逃しているのではないかと思います。

もし問題を再現する MIDI 信号の記録ができるようでしたら、.mid ファイルにしてこちらに送っていただければこちらでも再現するか試してみます。ふつうの MIDI レコーダですと厳密に記録してくれない可能性があるので、MIDI-OX を使うのがおすすめです。やり方をブログ記事に書いてみました。
http://gaje.jp/2017/01/17/3423/
7
製作上のご質問 / Re:Mini Board IIの動作
« 最新の投稿 by thunder 投稿日: 1月 16, 2017, 01:20:34 am »
フォトカプラの配線について、不良があったので直しました。ご指摘ありがとうございます。

ロータリースイッチを今までつけていなかったのですが、装着しました。するとスイッチが0のときは今までと同じ現象でしたが、それ以外にすると問題がほぼ解決しました。
GateとCVは正常に動作し、CVは1オクターブの差を1Vに調整できました。MIDIコントローラーからの信号にも反応していますし、ポルタメントのような現象もありません。

ただ、MIDIコンで演奏していると時々Gateが上がりっぱなしになってしまいます。また、ピッチベンドに反応するのですが、ピッチベンド後と前でかなり音程に差があります。
この点について何かご指導いただければ幸いです。

お手数ですが、引き続きよろしくお願い致します。
8
製作上のご質問 / Re:Mini Board IIの動作
« 最新の投稿 by Gan 投稿日: 1月 13, 2017, 05:10:48 pm »
引用
440Hzの基準音の再生は確認できました。

PWM信号についてですが、タクトスイッチを押すとパルスの連続のような波形がオシロで見られました。振幅が時間変化して波打ってるような形です。

これならプロセッサは正常に動作しているように思います。

引用
ポルタメント現象については、スイッチを押していない間のGateが3V程度、CVが6V程度の電圧が生じているため、スイッチを押していない時に常に高い音が鳴ってしまい、
スイッチを押したときに急激に音が低くなるという感じです。連続して複数のスイッチを押せば問題なく音階が感じられます。また、書籍にならってオフセット調整をしようとしたのですが、低いCを0V高いCを1Vにうまく調整できず、差が0.6V程度になってしまいます。
CVはスイッチを押していない間は0Vになる仕様でしょうか。プロセッサの14番ピンを図ると3.5Vが出ていましたがこれは正常でしょうか。

スイッチを押していない時の Gate は 0V に落ちるのが正常動作です。CV はスイッチを押していない時でも最後に押したキーの音階にあたる出力が出っ放しです。PWM 出力はフィルタを通した後 -2 倍の反転増幅器にかけるので、最低キーを押したときに14番ピンからは 5V 、最高キーを押したときに0V が出るように設計されています。最低キーは C0 です。ロータリースイッチを 0 に合わせて 「ド」のスイッチを押すと C0 になります。最高音は G10 です。ロータリースイッチを A に合わせて「ソ」のスイッチを押すと G10 になります。プログラムを確認してみましたが G10 よりも高いキーを押すとまた最低音に落ちてしまうように読めます(そうだとするとバグですごめんなさい)。ちょっとご注意ください。

参考まで、音階と MIDI ノート番号の対応はこのページの表がわかりやすいです。ノート番号は 0 から 127 まであります。MiniBoard の音階スイッチに対応しているノート番号も MIDI と同じです。
http://www.electronics.dit.ie/staff/tscarff/Music_technology/midi/midi_note_numbers_for_octaves.htm

引用
ローパスフィルタは動作しているようでした。

フィルタの平滑ができていて、ポルタメントのように遷移が遅れるようでしたら、フィルタの時係数が大きすぎる可能性もあります。フィルタまわりの抵抗とコンデンサの値は正しいでしょうか?他の可能性として、MiniBoard の出力と VCO を繋ぐ線に大きな容量がぶら下がっている、というようなことがもしかしたらあるかもしれません。

引用
フォトカプラ はTLP552を使用しています。プロセッサの2番ピンには常に3.7Vが来ており、オシロで見るとすこし揺らいでいます。TLP552の6番ピンからは常に5Vが出ており、オシロで見ると数秒に一回0Vに落ちていました。どちらもMIDIコントローラーには反応していません。手元にフォトカプラの予備がないのですが、新品との交換を検討します。

TLP552 の六番ピンは信号のない状態では 5V で固定されるはずです。信号が入ると細かく落ちる信号が見えるはずです。MIDI ケーブルを抜いた状態でもフォトカプラの信号が落ちるでしょうか?その場合、マイクロプロセッサも抜いてしまってフォトカプラの出力を観測してみると、フォトカプラとプロセッサのどちらに問題があるかわかるかもしれません。MIDI コントローラに反応しないのも気になります。

プロセッサの二番ピンはフォトカプラに直結しているので電圧はフォトカプラ6番ピンと同じになっていないといけません。この二点で電圧が異なっているとすると、どこかパタンが切れたり半田付けの不良があったりするかもしれません。
9
製作上のご質問 / Re:Mini Board IIの動作
« 最新の投稿 by thunder 投稿日: 1月 13, 2017, 12:01:02 am »
さっそくのご返答ありがとうございます。
440Hzの基準音の再生は確認できました。

PWM信号についてですが、タクトスイッチを押すとパルスの連続のような波形がオシロで見られました。振幅が時間変化して波打ってるような形です。

ポルタメント現象については、スイッチを押していない間のGateが3V程度、CVが6V程度の電圧が生じているため、スイッチを押していない時に常に高い音が鳴ってしまい、
スイッチを押したときに急激に音が低くなるという感じです。連続して複数のスイッチを押せば問題なく音階が感じられます。また、書籍にならってオフセット調整をしようとしたのですが、低いCを0V高いCを1Vにうまく調整できず、差が0.6V程度になってしまいます。
CVはスイッチを押していない間は0Vになる仕様でしょうか。プロセッサの14番ピンを図ると3.5Vが出ていましたがこれは正常でしょうか。

ローパスフィルタは動作しているようでした。

フォトカプラ はTLP552を使用しています。プロセッサの2番ピンには常に3.7Vが来ており、オシロで見るとすこし揺らいでいます。TLP552の6番ピンからは常に5Vが出ており、オシロで見ると数秒に一回0Vに落ちていました。どちらもMIDIコントローラーには反応していません。手元にフォトカプラの予備がないのですが、新品との交換を検討します。

長文で申し訳ありませんが、ご教授よろしくお願いいたします。
10
製作上のご質問 / Re:Mini Board IIの動作
« 最新の投稿 by Gan 投稿日: 1月 12, 2017, 05:00:37 pm »
thunder さんはじめまして。

鍵盤スイッチを押すとゲートが立ち上がるのならマイクロプロセッサの動作は正常なのではないかと思います。念のため、440Hz の基準音が出るかどうかで確認してみてはいかがでしょうか?ファンクションスイッチを1秒以上押し続けると圧電スピーカから基準音が出るようにプログラミングされています。

動作を読むと、CV の平滑回路に問題があるのではないかという気がします。CV 信号は、プロセッサの 14番ピンから PWM 信号として出てきます。プロセッサの14番ピンから R19 の左側まではローパスフィルタ回路で、これが平滑回路です。平滑回路は、高い周波数で動いている PWM 信号の動きを鈍くする回路なので、ここに問題があった場合 CV の遷移が遅くなることがあるような気がします。おすすめの確認方法は、

1. プロセッサ 14番ピンの出力波形をオシロスコープで観測して、きちんと PWM 信号になっているか確認する
2. R19 のプロセッサ側にテスターを当てるなり VCO を繋ぐなりしてみて、電圧が素早く遷移するか確認する

オシロスコープがなければ2番の確認だけでもしてみると問題の切り分けが進むかもしれません。

外部からの MIDI 信号を受け付けないのは CV の挙動とは別問題の可能性が高いです。MIDI 信号はフォトカプラ TLP552 の出力 (6番ピン) を介してプロセッサの 2番ピンに入ります。このピンに信号が来ているか確認してみるのはいかがでしょうか?フォトカプラに代用品を使っていたりしますか?TLP552 は反応の速いフォトカプラで、代用品を使うと MIDI 信号の波形がなまって読み取れなくなる、という問題が以前あったように記憶しています。

TL064 のかわりに TL084 を使うことは特に問題がないと思います。

ページ: [1] 2 3 ... 10